Can't scroll vertically

Dec 27, 2011 at 10:08 PM

Greetings,

   I just tried out this plug-in for the first time and I was surprised at how quick and easy it was to set up! Unfortunately the side effect of getting my page to navigate with left and right swipes is that I cannot scroll the page vertically anymore. I assume that the swipe function is apprehending the finger input that would normally allow the page to scroll vertically. Perhaps there is some simple way to allow vertical movement to pass-through to the default behaviour and only intercept horizontal movement?

So I want left and right to be next page and previous page. (This works)

and I want up and down to be the regular finger scroll. ( not sure what to do here )

Coordinator
Jan 4, 2012 at 7:19 PM

Hi,

I can't test this right now but I'm planning to release a new version as soon as I'm back from holidays (by the end of this month) with better handling of touch inputs, especially when using multi touch.

Till then you can try setting the preventDefault to false, so the default browser behaviour won't be ignored.

Feb 18, 2013 at 5:25 PM
I have the same problem.
I use the plugin for a website to show or hide the navigation. but the user can't scroll vertically anymore.
is there a solution for this?
can i use only left and right swipes and keep the vertical swipes with default browser behaviour?
Coordinator
Mar 13, 2013 at 4:51 PM
I'll get this done on a next release. Aiming to have it ready by next week ok?
Mar 14, 2013 at 6:53 AM
Hi,
I have an similar problem.

If I set the preventDefault to true , I will not scroll the page vertically anymore and even I set tapToClick to true,I still can not trigger a touch or click event in some browser
Mar 26, 2013 at 9:09 PM
Edited Mar 27, 2013 at 12:31 AM
Removed by poster
Mar 27, 2013 at 12:30 AM
Edited Mar 27, 2013 at 8:26 PM
Igon, I went ahead and forked your plugin to not capture a two finger pinch or expand so that users can navigate if they end up zooming in on an element with wipetouch enabled: http://pastie.org/7131093

Hope you find it useful. Thanks for making wipetouch.

-Andrew
Apr 16, 2013 at 11:34 PM
try adding
preventDefault: false,
tapToClick: false,